PCI Mandate for Internet Transmission Protocols

3/12/2018
Due to the updated PCI Council requirements for secure internet transmission protocols, payment processors are requiring the use of Transport Layer Security (TLS) 1.2 within all existing applications.  In order to support TLS 1.2, all customers using Oracle | MICROS software must ensure that they are on a supported version (see below). If your processor is not listed (ie: Shift4 DOtN), please reach out to your processor to identify the required version. 

 
Click here for more detail, or click here to contact our support team to discuss options!

<<< Back to News and Press Releases